有人说我是买应用中心的模板,来给大家使用的。那么问题来了,这么多免费分享的模板,我一个穷逼买得起给你们用吗?同行没实力的不要睁眼说瞎话,虽然“你”被我搞死了。
微信 手机版 Discuz!模板雇佣兵_忽悠兄 - Powered by Discuz! == 理想版V10 执行改版中,感谢大家支持 ==
 找回密码
 立即注册

扫一扫,访问微社区

QQ登录

只需一步,快速开始

1101216848

10:30-23:00, 节假日不休息

discuz X3.2模板升级到discuz X3.4的方法_版本号不匹配的解决方法 [复制链接]

xilecn 发表于 2018-9-26 15:21:23 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题
本帖最后由 xilecn 于 2018-9-26 03:22 PM 编辑

Discuz3.2模板98%都兼容Discuz3.4版本,不过由于discuz3.4的系统限制和模板配置文件里缺少3.4版本号的原因,直接安装3.2版本模板会提示【版本号不匹配,当前版本:X2.5,系统版本:X3.4】或者【版本号不匹配,当前版本:X3.2,系统版本:X3.4】等等类似的提示,


解决的方法很简单!就是为下载的模版增加对应的版本号即可!增加的方法如下:
1,首先找到你下载的模版的【模板配置文件】,这个文件一般就是在【模板的文件夹第一层】,如下图:这个文件通常文件名是 discuz_style_***_.xml ,在配置文件所在的文件夹一般有两个图片文件,名字分别为:preview.jpg和preview_large.jpg,这样就可以很简单的找到配置文件了!


,我们用Notepad++编辑器(不要用记事本,容易乱码)打开这个配置文件,可以看到这样的一段配置代码,类似如下代码:

  1. <item id="Version"><![CDATA[X2.5]]></item>
复制代码


当然也有可能是这样的


  1. <item id="Version"><![CDATA[X2.5,X3,X3.1]]></item>
复制代码


可以看到,这里就是Discuz模板的版本号配置了,如果提示不支持3.4,那么我们只需要在后面先加上一个英文的分号,然后加上X3.4即可!添加后如下:
  1. <item id="Version"><![CDATA[X2.5,X3.1,X3.2,X3.3,X3.4,L1.0]]></item>
复制代码


如果不会添加,可以复制上面这段代码,替换配置文件里面的代码即可!同时,在配置文件最底部一般会有一个同样的代码段,和上面的是一样的,按照上述方法增加版本号即可!也就是说,你在这个文件总共需要修改两次(可能有的模板只有一个,那么就修改一个即可!)


最终修改完毕的效果如下:
2345截图20180926151948.png


3,全部修改完毕,保存后重新上传安装即可!如下图,已经可以正常安装了!
2345截图20180926152035.png



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

网站通告上一条 /1 下一条

现在马上加入忽悠兄基地,注册一个账号 本站账号登陆 QQ账号登陆 微信账号登陆
快速回复 返回顶部 返回列表